CryptoSwift

CryptoSwift is a growing collection of standard and secure cryptographic algorithms implemented in Swift (by krzyzanowskim)

Stats

Basic CryptoSwift repo stats
4
8,431
7.1
10 days ago

krzyzanowskim/CryptoSwift is an open source project licensed under NOASSERTION which is not an OSI approved license.

CryptoSwift Alternatives

Similar projects and alternatives to CryptoSwift based on common topics and language

  • GitHub repo swift-corelibs-foundation

    The Foundation Project, providing core utilities, internationalization, and OS independence

  • GitHub repo iOS-UIKit

    UI Kit for the Agora Video iOS and macOS RTC SDK

  • GitHub repo Saga

    A static site generator written in Swift

  • GitHub repo SwCrypt

    RSA public/private key generation, RSA, AES encryption/decryption, RSA sign/verify in Swift with CommonCrypto in iOS and OS X

  • GitHub repo SCrypto

    Elegant Swift interface to access the CommonCrypto routines (by sgl0v)

  • GitHub repo BlueCryptor

    Swift cross-platform crypto library using CommonCrypto/libcrypto

  • GitHub repo hashes

    Collection of cryptographic hash functions written in pure Rust

NOTE: The number of mentions on this list indicates mentions on common posts. Hence, a higher number means a better CryptoSwift alternative or higher similarity.

Posts

Posts where CryptoSwift has been mentioned. We have used some of these posts to build our list of alternatives and similar projects - the last one was on 2021-03-02.
  • How do you implement HMAC SHA1 in today's Swift?
    reddit.com/r/swift | 2021-04-30
    You can try this lib: https://github.com/krzyzanowskim/CryptoSwift
  • Crypto related functions and helpers for Swift
  • What’s everyone working on this month? (March 2021)
    reddit.com/r/swift | 2021-03-02
    Made a pull request in the CryptoSwift package https://github.com/krzyzanowskim/CryptoSwift/pull/855
  • Successor to RNCryptor?
    reddit.com/r/swift | 2021-02-16
    I recently used https://github.com/krzyzanowskim/CryptoSwift for AES-GCM that needed ios 13 or below