Bearer VS request

Compare Bearer vs request and see what are their differences.

Bearer

By Bearer

request

🏊🏾 Simplified HTTP request client. (by request)
Our great sponsors
  • SonarLint - Deliver Cleaner and Safer Code - Right in Your IDE of Choice!
  • OPS - Build and Run Open Source Unikernels
  • Scout APM - Less time debugging, more time building
Bearer request
0 32
18 25,401
- 0.1%
1.3 0.0
- 4 days ago
TypeScript JavaScript
- Apache License 2.0
The number of mentions indicates the total number of mentions that we've tracked plus the number of user suggested alternatives.
Stars - the number of stars that a project has on GitHub. Growth - month over month growth in stars.
Activity is a relative number indicating how actively a project is being developed. Recent commits have higher weight than older ones.
For example, an activity of 9.0 indicates that a project is amongst the top 10% of the most actively developed projects that we are tracking.

Bearer

Posts with mentions or reviews of Bearer. We have used some of these posts to build our list of alternatives and similar projects.

We haven't tracked posts mentioning Bearer yet.
Tracking mentions began in Dec 2020.

request

Posts with mentions or reviews of request. We have used some of these posts to build our list of alternatives and similar projects. The last one was on 2022-01-10.
  • Got 54 vulnerabilities, after installing parcel bundler npm for development
    3 projects | reddit.com/r/reactjs | 10 Jan 2022
    npm WARN deprecated [email protected]: request-promise-native has been deprecated because it extends the now deprecated request package, see https://github.com/request/request/issues/3142 npm WARN deprecated [email protected]: this library is no longer supported npm WARN deprecated [email protected]: Please see https://github.com/lydell/urix#deprecated npm WARN deprecated [email protected]: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies. npm WARN deprecated [email protected]: https://github.com/lydell/resolve-url#deprecated npm WARN deprecated [email protected]: The querystring API is considered Legacy. new code should use the URLSearchParams API instead. npm WARN deprecated [email protected]: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. npm WARN deprecated [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142 npm WARN deprecated [email protected]: This SVGO version is no longer supported. Upgrade to v2.x.x. npm WARN deprecated [email protected]: Parcel v1 is no longer maintained. Please migrate to v2, which is published under the 'parcel' package. See https://v2.parceljs.org/getting-started/migration for details. npm WARN deprecated [email protected]: [email protected]<3.4 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js. added 788 packages, and audited 790 packages in 60s 53 packages are looking for funding run `npm fund` for details 54 vulnerabilities (1 low, 48 moderate, 5 high)
  • Request not working in NodeJS but working in Python
    1 project | reddit.com/r/node | 4 Jan 2022
    a) request is deprecated (https://www.npmjs.com/package/request), use axios, some other package, or the built-in http client
  • Homebridge TCC plug-in
    1 project | reddit.com/r/homebridge | 29 Dec 2021
    CMD: npm install -g [email protected] npm WARN deprecated [email protected]: This module has moved and is now available at u/hapi/hoek. Please update your dependencies as this version is no longer maintained an may contain bugs and security issues. npm WARN deprecated [email protected]: this library is no longer supported npm WARN deprecated [email protected]: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial). npm WARN deprecated [email protected]: This module has moved and is now available at @hapi/topo. Please update your dependencies as this version is no longer maintained an may contain bugs and security issues. npm WARN deprecated [email protected]: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial). npm WARN deprecated [email protected]: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. npm WARN deprecated [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142 npm WARN deprecated [email protected]: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial). npm ERR! code 1 npm ERR! path /volume1/@appdata/homebridge/lib/node_modules/homebridge-tcc/node_modules/node-expat npm ERR! command failed npm ERR! command sh -c node-gyp rebuild npm ERR! gyp info it worked if it ends with ok npm ERR! gyp info using [email protected] npm ERR! gyp info using [email protected] | linux | x64 npm ERR! gyp info find Python using Python version 3.8.8 found at "/usr/bin/python3.8" npm ERR! gyp info spawn /usr/bin/python3.8 npm ERR! gyp info spawn args [ npm ERR! gyp info spawn args '/volume1/@appstore/homebridge/app/lib/node_modules/npm/node_modules/node-gyp/gyp/gyp_main.py', npm ERR! gyp info spawn args 'binding.gyp', npm ERR! gyp info spawn args '-f', npm ERR! gyp info spawn args 'make', npm ERR! gyp info spawn args '-I', npm ERR! gyp info spawn args '/volume1/@appdata/homebridge/lib/node_modules/homebridge-tcc/node_modules/node-expat/build/config.gypi', npm ERR! gyp info spawn args '-I', npm ERR! gyp info spawn args '/volume1/@appstore/homebridge/app/lib/node_modules/npm/node_modules/node-gyp/addon.gypi', npm ERR! gyp info spawn args '-I', npm ERR! gyp info spawn args '/var/packages/homebridge/home/.cache/node-gyp/16.13.1/include/node/common.gypi', npm ERR! gyp info spawn args '-Dlibrary=shared_library', npm ERR! gyp info spawn args '-Dvisibility=default', npm ERR! gyp info spawn args '-Dnode_root_dir=/var/packages/homebridge/home/.cache/node-gyp/16.13.1', npm ERR! gyp info spawn args '-Dnode_gyp_dir=/volume1/@appstore/homebridge/app/lib/node_modules/npm/node_modules/node-gyp', npm ERR! gyp info spawn args '-Dnode_lib_file=/var/packages/homebridge/home/.cache/node-gyp/16.13.1/
  • how to fix "[webpack-cli] Invalid configuration object. Webpack has been initialized using a configuration object that does not match the API schema" error?
    1 project | reddit.com/r/rails | 28 Dec 2021
    npm WARN deprecated [email protected]: this library is no longer supported npm WARN deprecated [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142 npm WARN deprecated [email protected]: This version of tar is no longer supported, and will not receive security updates. Please upgrade asap. npm ERR! path /Users/me/code/site/node_modules/node-sass npm ERR! command failed npm ERR! signal SIGINT npm ERR! command sh -c node scripts/build.js npm ERR! Building: /Users/me/.nvm/versions/node/v16.10.0/bin/node /Users/me/code/site/node_modules/node-gyp/bin/node-gyp.js rebuild --verbose --libsass_ext= --libsass_cflags= --libsass_ldflags= --libsass_library= npm ERR! c++ '-DNODE_GYP_MODULE_NAME=libsass' '-DUSING_UV_SHARED=1' '-DUSING_V8_SHARED=1' '-DV8_DEPRECATION_WARNINGS=1' '-DV8_DEPRECATION_WARNINGS' '-DV8_IMMINENT_DEPRECATION_WARNINGS' '-D_GLIBCXX_USE_CXX11_ABI=1' '-D_DARWIN_USE_64_BIT_INODE=1' '-D_LARGEFILE_SOURCE' '-D_FILE_OFFSET_BITS=64' '-DOPENSSL_NO_PINSHARED' '-DOPENSSL_THREADS' '-DLIBSASS_VERSION="3.5.5"' -I/Users/me/.node-gyp/16.10.0/include/node -I/Users/me/.node-gyp/16.10.0/src -I/Users/me/.node-gyp/16.10.0/deps/openssl/config -I/Users/me/.node-gyp/16.10.0/deps/openssl/openssl/include -I/Users/me/.node-gyp/16.10.0/deps/uv/include -I/Users/me/.node-gyp/16.10.0/deps/zlib -I/Users/me/.node-gyp/16.10.0/deps/v8/include -I../src/libsass/include -O3 -gdwarf-2 -mmacosx-version-min=10.7 -arch x86_64 -Wall -Wendif-labels -W -Wno-unused-parameter -std=c++11 -stdlib=libc++ -fno-strict-aliasing -MMD -MF ./Release/.deps/Release/obj.target/libsass/src/libsass/src/ast.o.d.raw -c -o Release/obj.target/libsass/src/libsass/src/ast.o ../src/libsass/src/ast.cpp npm ERR! gyp info it worked if it ends with ok npm ERR! gyp verb cli [ npm ERR! gyp verb cli '/Users/me/.nvm/versions/node/v16.10.0/bin/node', npm ERR! gyp verb cli '/Users/me/code/site/node_modules/node-gyp/bin/node-gyp.js', npm ERR! gyp verb cli 'rebuild', npm ERR! gyp verb cli '--verbose', npm ERR! gyp verb cli '--libsass_ext=', npm ERR! gyp verb cli '--libsass_cflags=', npm ERR! gyp verb cli '--libsass_ldflags=', npm ERR! gyp verb cli '--libsass_library=' npm ERR! gyp verb cli ] npm ERR! gyp info using [email protected] npm ERR! gyp info using [email protected] | darwin | x64 npm ERR! gyp verb command rebuild [] npm ERR! gyp verb command clean [] npm ERR! gyp verb clean removing "build" directory npm ERR! gyp verb command configure [] npm ERR! gyp verb check python checking for Python executable "python2" in the PATH npm ERR! gyp verb `which` succeeded python2 /usr/bin/python2 npm ERR! gyp verb check python version `/usr/bin/python2 -c "import sys; print "2.7.16 npm ERR! gyp verb check python version .%s.%s" % sys.version_info[:3];"` returned: %j npm ERR! gyp verb get node dir no --target version specified, falling back to host node version: 16.10.0 npm ERR! gyp verb command install [ '16.10.0' ] npm ERR! gyp verb install input version string "16.10.0" npm ERR! gyp verb install installing version: 16.10.0 npm ERR! gyp verb install --ensure was passed, so won't reinstall if already installed npm ERR! gyp verb install version is already installed, need to check "installVersion" npm ERR! gyp verb got "installVersion" 9 npm ERR! gyp verb needs "installVersion" 9 npm ERR! gyp verb install version is good npm ERR! gyp verb get node dir target node version installed: 16.10.0 npm ERR! gyp verb build dir attempting to create "build" dir: /Users/me/code/site/node_modules/node-sass/build npm ERR! gyp verb build dir "build" dir needed to be created? /Users/me/code/site/node_modules/node-sass/build npm ERR! gyp verb build/config.gypi creating config file npm ERR! gyp verb build/config.gypi writing out config file: /Users/me/code/site/node_modules/node-sass/build/config.gypi npm ERR! (node:33991) [DEP0150] DeprecationWarning: Setting process.config is deprecated. In the future the property will be read-only. npm ERR! (Use `node --trace-deprecation ...` to show where the warning was created) npm ERR! gyp verb config.gypi checking for gypi file: /Users/me/code/site/node_modules/node-sass/config.gypi npm ERR! gyp verb common.gypi checking for gypi file: /Users/me/code/site/node_modules/node-sass/common.gypi npm ERR! gyp verb gyp gyp format was not specified; forcing "make" npm ERR! gyp info spawn /usr/bin/python2 npm ERR! gyp info spawn args [ npm ERR! gyp info spawn args '/Users/me/code/site/node_modules/node-gyp/gyp/gyp_main.py', npm ERR! gyp info spawn args 'binding.gyp', npm ERR! gyp info spawn args '-f', npm ERR! gyp info spawn args 'make', npm ERR! gyp info spawn args '-I', npm ERR! gyp info spawn args '/Users/me/code/site/node_modules/node-sass/build/config.gypi', npm ERR! gyp info spawn args '-I', npm ERR! gyp info spawn args '/Users/me/code/site/node_modules/node-gyp/addon.gypi', npm ERR! gyp info spawn args '-I', npm ERR! gyp info spawn args '/Users/me/.node-gyp/16.10.0/include/node/common.gypi', npm ERR! gyp info spawn args '-Dlibrary=shared_library', npm ERR! gyp info spawn args '-Dvisibility=default', npm ERR! gyp info spawn args '-Dnode_root_dir=/Users/me/.node-gyp/16.10.0', npm ERR! gyp info spawn args '-Dnode_gyp_dir=/Users/me/code/site/node_modules/node-gyp', npm ERR! gyp info spawn args '-Dnode_lib_file=/Users/me/.node-gyp/16.10.0/' creates a copy from type 'const std::__1::basic_string, std::__1::allocator >' [-Wrange-loop-analysis] npm ERR! for (const auto numerator : numerators) npm ERR! ^ npm ERR! ../src/libsass/src/ast.hpp:1614:14: note: use reference type 'const std::__1::basic_string, std::__1::allocator > &' to prevent copying npm ERR! for (const auto numerator : numerators) npm ERR! ^~~~~~~~~~~~~~~~~~~~~~ npm ERR! & npm ERR! ../src/libsass/src/ast.hpp:1616:25: warning: loop variable 'denominator' of type 'const std::__1::basic_string, std::__1::allocator >' creates a copy from type 'const std::__1::basic_string, std::__1::allocator >' [-Wrange-loop-analysis] npm ERR! for (const auto denominator : denominators) npm ERR! ^ npm ERR! ../src/libsass/src/ast.hpp:1616:14: note: use reference type 'const std::__1::basic_string, std::__1::allocator > &' to prevent copying npm ERR! for (const auto denominator : denominators) npm ERR! ^~~~~~~~~~~~~~~~~~~~~~~~ npm ERR! & npm ERR! make: *** [Release/obj.target/libsass/src/libsass/src/ast.o] Interrupt: 2 npm ERR! A complete log of this run can be found in: npm ERR! /Users/me/.npm/_logs/2021-12-28T19_19_43_151Z-debug.log
  • npx create-react-app not working -- everything is deprecated
    5 projects | reddit.com/r/react | 11 Dec 2021
    Installing packages. This might take a couple of minutes. Installing react, react-dom, and react-scripts with cra-template... ➤ YN0000: ┌ Resolution step ➤ YN0061: │ [email protected]:10.1.0 is deprecated: babel-eslint is now u/babel/eslint-parser. This package will no longer receive updates. ➤ YN0032: │ [email protected]:2.3.2: Implicit dependencies on node-gyp are discouraged ➤ YN0061: │ [email protected]:4.4.0 is deprecated: This package has been deprecated and is no longer maintained. Please use u/rollup/plugin-babel. ➤ YN0061: │ [email protected]:0.2.1 is deprecated: The querystring API is considered Legacy. new code should use the URLSearchParams API instead. ➤ YN0061: │ u/hapi/[email protected]:15.1.1 is deprecated: Switch to 'npm install joi' ➤ YN0061: │ [email protected]:2.1.8 is deprecated: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies. ➤ YN0061: │ [email protected]:1.2.13 is deprecated: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2. ➤ YN0061: │ [email protected]:1.3.2 is deprecated: This SVGO version is no longer supported. Upgrade to v2.x.x. ➤ YN0061: │ [email protected]:0.2.0 is deprecated: The querystring API is considered Legacy. new code should use the URLSearchParams API instead. ➤ YN0061: │ [email protected]:0.1.0 is deprecated: Please see https://github.com/lydell/urix#deprecated ➤ YN0061: │ u/hapi/[email protected]:2.1.4 is deprecated: Moved to 'npm install u/sideway/address' ➤ YN0061: │ u/hapi/[email protected]:1.3.2 is deprecated: This version has been deprecated and is no longer supported or maintained ➤ YN0061: │ u/hapi/[email protected]:3.1.6 is deprecated: This version has been deprecated and is no longer supported or maintained ➤ YN0061: │ u/hapi/[email protected]:8.5.1 is deprecated: This version has been deprecated and is no longer supported or maintained ➤ YN0032: │ [email protected]:2.14.2: Implicit dependencies on node-gyp are discouraged ➤ YN0061: │ [email protected]:2.6.12 is deprecated: [email protected]<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js. ➤ YN0061: │ [email protected]:3.4.0 is deprecated: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. ➤ YN0061: │ [email protected]:1.0.3 is deprecated: flatten is deprecated in favor of utility frameworks such as lodash. ➤ YN0061: │ [email protected]:4.1.0 is deprecated: some dependency vulnerabilities fixed, support for node < 10 dropped, and newer ECMAScript syntax/features added ➤ YN0061: │ [email protected]:0.2.1 is deprecated: https://github.com/lydell/resolve-url#deprecated ➤ YN0032: │ [email protected]:1.0.3: Implicit dependencies on node-gyp are discouraged ➤ YN0061: │ [email protected]:2.88.2 is deprecated: request has been deprecated, see https://github.com/request/request/issues/3142 ➤ YN0061: │ [email protected]:1.0.9 is deprecated: request-promise-native has been deprecated because it extends the now deprecated request package, see https://github.com/request/request/issues/3142 ➤ YN0061: │ [email protected]:5.1.5 is deprecated: this library is no longer supported ➤ YN0002: │ [email protected]:11.0.4 doesn't provide typescript (p79ddf), requested by fork-ts-checker-webpack-plugin ➤ YN0002: │ [email protected]:11.0.4 doesn't provide webpack (p2af19), requested by fork-ts-checker-webpack-plugin ➤ YN0000: │ Some peer dependencies are incorrectly met; run yarn explain peer-requirements for details, where is the six-letter p-prefixed code ➤ YN0000: └ Completed in 24s 290ms ➤ YN0000: ┌ Fetch step ➤ YN0013: │ [email protected]:13.1.2 can't be found in the cache and will be fetched from the remote registry ➤ YN0013: │ [email protected]:18.1.3 can't be found in the cache and will be fetched from the remote registry ➤ YN0013: │ [email protected]:13.3.2 can't be found in the cache and will be fetched from the remote registry ➤ YN0013: │ [email protected]:15.4.1 can't be found in the cache and will be fetched from the remote registry ➤ YN0013: │ [email protected]:0.1.0 can't be found in the cache and will be fetched from the remote registry ➤ YN0000: └ Completed in 2s 306ms ➤ YN0000: ┌ Link step ➤ YN0000: │ ESM support for PnP uses the experimental loader API and is therefore experimental ➤ YN0007: │ [email protected]:3.9.0 must be built because it never has been before or the last one failed ➤ YN0007: │ [email protected]:3.9.0 must be built because it never has been before or the last one failed ➤ YN0007: │ [email protected]:[email protected]%3A1.2.13#~builtin::version=1.2.13&hash=18f3a7 must be built because it never has been before or the last one failed ➤ YN0007: │ [email protected]:2.7.4 must be built because it never has been before or the last one failed ➤ YN0007: │ [email protected]:2.6.12 must be built because it never has been before or the last one failed ➤ YN0000: └ Completed in 6s 29ms ➤ YN0000: Done with warnings in 32s 871ms node:internal/modules/cjs/loader:936 throw err; ^ Error: Cannot find module 'react-scripts/scripts/init.js' Require stack: - /Users/SchindlersKiss/Desktop/basics/[eval] at Function.Module._resolveFilename (node:internal/modules/cjs/loader:933:15) at Function.Module._load (node:internal/modules/cjs/loader:778:27) at Module.require (node:internal/modules/cjs/loader:1005:19) at require (node:internal/modules/cjs/helpers:102:18) at [eval]:2:20 at Script.runInThisContext (node:vm:129:12) at Object.runInThisContext (node:vm:305:38) at node:internal/process/execution:75:19 at [eval]-wrapper:6:22 at evalScript (node:internal/process/execution:74:60) { code: 'MODULE_NOT_FOUND', requireStack: [ '/Users/SchindlersKiss/Desktop/basics/[eval]' ] } Aborting installation. node has failed. Deleting generated file... package.json Deleting generated file... yarn.lock
  • can't install ganashe through npm
    5 projects | reddit.com/r/Truffle | 13 Nov 2021
    npm install npm WARN old lockfile npm WARN old lockfile The package-lock.json file was created with an old version of npm, npm WARN old lockfile so supplemental metadata must be fetched from the registry. npm WARN old lockfile npm WARN old lockfile This is a one-time fix-up, please be patient... npm WARN old lockfile npm WARN EBADENGINE Unsupported engine { npm WARN EBADENGINE package: '[email protected]', npm WARN EBADENGINE required: { node: '12.13.1' }, npm WARN EBADENGINE current: { node: 'v16.11.1', npm: '8.1.3' } npm WARN EBADENGINE } npm WARN deprecated [email protected]: Renamed to @metamask/safe-event-emitter npm WARN deprecated [email protected]: Please update to ini >=1.3.6 to avoid a prototype pollution issue npm WARN deprecated [email protected]: This package is broken and no longer maintained. 'mkdirp' itself supports promises now, please switch to that. npm WARN deprecated [email protected]: flatten is deprecated in favor of utility frameworks such as lodash. npm WARN deprecated [email protected]: This package is broken and no longer maintained. 'mkdirp' itself supports promises now, please switch to that. npm WARN deprecated [email protected]: request-promise-native has been deprecated because it extends the now deprecated request package, see https://github.com/request/request/issues/3142 npm WARN deprecated [email protected]: Please see https://github.com/lydell/urix#deprecated npm WARN deprecated [email protected]: this library is no longer supported npm WARN deprecated [email protected]: Please see https://github.com/lydell/urix#deprecated npm WARN deprecated [email protected]: this library is no longer supported npm WARN deprecated @web3-js/[email protected]: This package is deprecated, for a pure JS implementation please use scrypt-js npm WARN deprecated [email protected]: Deprecated in favor of '@metamask/eth-sig-util' npm WARN deprecated [email protected]: Please use Util.Account class found on package [email protected]^7.0.6 https://github.com/ethereumjs/ethereumjs-util/releases/tag/v7.0.6 npm WARN deprecated [email protected]: https://github.com/lydell/resolve-url#deprecated npm WARN deprecated [email protected]: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools. npm WARN deprecated [email protected]: https://github.com/lydell/resolve-url#deprecated npm WARN deprecated [email protected]: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools. npm WARN deprecated [email protected]: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools. npm WARN deprecated [email protected]: use String.prototype.padStart() npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/block. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/block. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/block. Please update. npm WARN deprecated [email protected]: Deprecated in favor of '@metamask/eth-sig-util' npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/block. Please update. npm WARN deprecated [email protected]: some dependency vulnerabilities fixed, support for node < 10 dropped, and newer ECMAScript syntax/features added npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies. npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies. npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797) npm WARN deprecated [email protected]: The querystring API is considered Legacy. new code should use the URLSearchParams API instead. npm WARN deprecated [email protected]: We don't use this library anymore so you shouldn't either. Use e.g. 'uuid' instead! npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/tx. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/tx. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/tx. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/tx. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/tx. Please update. npm WARN deprecated [email protected]: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. npm WARN deprecated [email protected]: babel-eslint is now @babel/eslint-parser. This package will no longer receive updates. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/ethash. Please update. npm WARN deprecated [email protected]: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. npm WARN deprecated [email protected]: This module has been superseded by the multiformats module npm WARN deprecated [email protected]: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. npm WARN deprecated [email protected]: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. npm WARN deprecated [email protected]: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. npm WARN deprecated [email protected]: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. npm WARN deprecated [email protected]: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.) npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/blockchain. Please update. npm WARN deprecated [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142 npm WARN deprecated [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142 npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/tx. Please update. npm WARN deprecated [email protected]: This module has been superseded by the multiformats module npm WARN deprecated [email protected]: This module has been superseded by the multiformats module npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/tx. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/tx. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/tx. Please update. npm WARN deprecated [email protected]: This module has been superseded by the multiformats module npm WARN deprecated @web3-js/[email protected]: The branch for this fork was merged upstream, please update your package to [email protected] npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/vm. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/vm. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/vm. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/block. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/block. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/block. Please update. npm WARN deprecated [email protected]: This SVGO version is no longer supported. Upgrade to v2.x.x. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/common. Please update. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/common. Please update. npm WARN deprecated [email protected]: This SVGO version is no longer supported. Upgrade to v2.x.x. npm WARN deprecated [email protected]: New package name format for new versions: @ethereumjs/vm. Please update. npm WARN deprecated [email protected]: This module has been superseded by the multiformats module npm WARN deprecated [email protected]: This version of tar is no longer supported, and will not receive security updates. Please upgrade asap. npm WARN deprecated [email protected]: Version no longer supported. Upgrade to @latest npm WARN deprecated [email protected]: [email protected]<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js. npm WARN deprecated [email protected]: [email protected]<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js. npm WARN deprecated [email protected]: [email protected]<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js. npm ERR! code 1 npm ERR! path /home/mehdielghali/Desktop/ganache-ui/node_modules/node-sass npm ERR! command failed npm ERR! command sh -c node scripts/build.js npm ERR! Building: /usr/bin/node /home/mehdielghali/Desktop/ganache-ui/node_modules/node-gyp/bin/node-gyp.js rebuild --verbose --libsass_ext= --libsass_cflags= --libsass_ldflags= --libsass_library= npm ERR! gyp info it worked if it ends with ok npm ERR! gyp verb cli [ npm ERR! gyp verb cli '/usr/bin/node', npm ERR! gyp verb cli '/home/mehdielghali/Desktop/ganache-ui/node_modules/node-gyp/bin/node-gyp.js', npm ERR! gyp verb cli 'rebuild', npm ERR! gyp verb cli '--verbose', npm ERR! gyp verb cli '--libsass_ext=', npm ERR! gyp verb cli '--libsass_cflags=', npm ERR! gyp verb cli '--libsass_ldflags=', npm ERR! gyp verb cli '--libsass_library=' npm ERR! gyp verb cli ] npm ERR! gyp info using [email protected] npm ERR! gyp info using [email protected] | linux | x64 npm ERR! gyp verb command rebuild [] npm ERR! gyp verb command clean [] npm ERR! gyp verb clean removing "build" directory npm ERR! gyp verb command configure [] npm ERR! gyp verb check python checking for Python executable "/usr/bin/python3" in the PATH npm ERR! gyp verb `which` succeeded /usr/bin/python3 /usr/bin/python3 npm ERR! gyp ERR! configure error npm ERR! gyp ERR! stack Error: Command failed: /usr/bin/python3 -c import sys; print "%s.%s.%s" % sys.version_info[:3]; npm ERR! gyp ERR! stack File "", line 1 npm ERR! gyp ERR! stack import sys; print "%s.%s.%s" % sys.version_info[:3]; npm ERR! gyp ERR! stack ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ npm ERR! gyp ERR! stack SyntaxError: Missing parentheses in call to 'print'. Did you mean print(...)? npm ERR! gyp ERR! stack npm ERR! gyp ERR! stack at ChildProcess.exithandler (node:child_process:397:12) npm ERR! gyp ERR! stack at ChildProcess.emit (node:events:390:28) npm ERR! gyp ERR! stack at maybeClose (node:internal/child_process:1064:16) npm ERR! gyp ERR! stack at Process.ChildProcess._handle.onexit (node:internal/child_process:301:5) npm ERR! gyp ERR! System Linux 5.14.16-301.fc35.x86_64 npm ERR! gyp ERR! command "/usr/bin/node" "/home/mehdielghali/Desktop/ganache-ui/node_modules/node-gyp/bin/node-gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library=" npm ERR! gyp ERR! cwd /home/mehdielghali/Desktop/ganache-ui/node_modules/node-sass npm ERR! gyp ERR! node -v v16.11.1 npm ERR! gyp ERR! node-gyp -v v3.8.0 npm ERR! gyp ERR! not ok npm ERR! Build failed with error code: 1 npm ERR! A complete log of this run can be found in: npm ERR! /home/mehdielghali/.npm/_logs/2021-11-14T02_59_08_900Z-debug.log
  • Por que motivo uso NodeJS para backend
    2 projects | reddit.com/r/devpt | 18 Oct 2021
  • Shoul I go with Axios or an other library?
    3 projects | reddit.com/r/reactnative | 3 Sep 2021
    As of Feb 11th 2020, request is fully deprecated. No new changes are expected to land. In fact, none have landed for some time. For more information about why request is deprecated and possible alternatives refer to https://github.com/request/request/issues/3142.
    3 projects | reddit.com/r/reactnative | 3 Sep 2021
    https://github.com/request/request try this
  • NPM deprecated warning
    3 projects | reddit.com/r/npm | 7 Aug 2021
    npm WARN deprecated [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142

What are some alternatives?

When comparing Bearer and request you can also consider the following projects:

axios - Promise based HTTP client for the browser and node.js

node-fetch - A light-weight module that brings the Fetch API to Node.js

superagent - Ajax for Node.js and browsers (JS HTTP client)

supertest - 🕷 Super-agent driven library for testing node.js HTTP servers using a fluent API.

wreck - HTTP Client Utilities

undici - An HTTP/1.1 client, written from scratch for Node.js

puppeteer - Headless Chrome Node.js API

hyperquest - make streaming http requests

lodash - A modern JavaScript utility library delivering modularity, performance, & extras.

got - 🌐 Human-friendly and powerful HTTP request library for Node.js

window.fetch polyfill - A window.fetch JavaScript polyfill.

pactum - REST API Testing Tool for all levels in a Test Pyramid