SaaSHub helps you find the best software and product alternatives Learn more →
Git-hooks.nix Alternatives
Similar projects and alternatives to git-hooks.nix
-
-
CodeRabbit
CodeRabbit: AI Code Reviews for Developers. Revolutionize your code reviews with AI. CodeRabbit offers PR summaries, code walkthroughs, 1-click suggestions, and AST-based analysis. Boost productivity and code quality across all major languages with each PR.
-
-
-
-
-
-
-
Nutrient
Nutrient – The #1 PDF SDK Library, trusted by 10K+ developers. Other PDF SDKs promise a lot - then break. Laggy scrolling, poor mobile UX, tons of bugs, and lack of support cost you endless frustrations. Nutrient’s SDK handles billion-page workloads - so you don’t have to debug PDFs. Used by ~1 billion end users in more than 150 different countries.
-
biome
A toolchain for web projects, aimed to provide functionalities to maintain them. Biome offers formatter and linter, usable via CLI and LSP.
-
pip-audit
Audits Python environments, requirements files and dependency trees for known security vulnerabilities, and can automatically fix them
-
lemmy-help
Every one needs help, so lemmy-help you! A CLI to generate vim/nvim help doc from emmylua
-
-
-
-
-
-
-
-
-
-
lua-typecheck-action
A GitHub action that lets you leverage sumneko lua-language-server and EmmyLua to statically type check lua code.
-
SaaSHub
SaaSHub - Software Alternatives and Reviews. SaaSHub helps you find the best software and product alternatives
git-hooks.nix discussion
git-hooks.nix reviews and mentions
-
Hk, a new Git hook manager from jdx
I use https://github.com/cachix/git-hooks.nix which provides all of it:
- Pre-commit hook setup
-
Fast, Declarative, Reproduble and Composable Developer Environments Using Nix
> Good luck getting answers on those questions other than "read the source code" and then followed by "no, not that source code, this branch here".
I experienced a similar situation last week with git-hooks.nix[1], a pre-commit integration for Nix.
I wanted to run biome[2] checks on my repository during pre-push so I wrote a custom hook because git-hooks.nix has pre-defined integrations with prettier and rome, but not biome.
Or that's what I thought. I eventually found out that the rome hook is actually referred as "rome" everywhere but calls biome instead[3]. This wasn't documented anywhere, so I opened an issue[4] suggesting to rename the hook to "biome" and keep the former for backwards compatibility reasons.
As of today, this has been acknowledged by one of the maintainers, whose sole feedback has been to "thumb down" the issue.
TL;DR: It's not just the documentation, but also the code not doing what you would expect. It also seems there's no means to improve the situation other than just forking the project since there's also clearly some kind of communication problem.
[1] https://github.com/cachix/git-hooks.nix
-
Any good alternative to husky in rust to enforce and write conventional commits and for pre-commit source code linting??
Anyone who already uses Nix and Flakes can use this integration. Anyone who doesn't use Nix can just ignore me, because I'm not here to try converting unconvinced folks.
-
Plugin devs: type check your lua plugins with lua-language-server and EmmyLua (GitHub action)
I don't think it does. I might look into implementimg it though, because I use pre-commit-hooks.nix in my own projects' CI.
-
Pre-commit: framework for managing/maintaining multi-language pre-commit hooks
> My least favourite bug is that it doesn't always play nicely with NixOS [1], and the maintainer locked me out of the issue for pointing it out.
Oof. Does this solve the problem https://github.com/cachix/pre-commit-hooks.nix (using Nix to manage dependencies)?
I was looking at pre-commit the other day, and wanted to incorporate it into the Nix setup of my projects.
-
y|sndr - Hooking up with Git - A nix managed solution to git hook management
Was it not possible to use something like this? https://github.com/cachix/pre-commit-hooks.nix
-
Statix — Lints and Suggestions for the Nix programming language
Maybe consider adding this to https://github.com/cachix/pre-commit-hooks.nix once you feel it's mature enough.
-
A note from our sponsor - SaaSHub
www.saashub.com | 18 Feb 2025
Stats
cachix/git-hooks.nix is an open source project licensed under Apache License 2.0 which is an OSI approved license.
The primary programming language of git-hooks.nix is Nix.