Error with every character in LUA-files

This page summarizes the projects mentioned and recommended in the original post on reddit.com/r/neovim

Our great sponsors
  • SonarLint - Clean code begins in your IDE with SonarLint
  • InfluxDB - Build time-series-based applications quickly and at scale.
  • Zigi - Workflow assistant built for devs & their teams
  • Scout APM - Truly a developer’s best friend
  • Neovim-from-scratch

    📚 A Neovim config designed from scratch to be understandable

    Hey! Been a couple of years since I've tried to setup NeoVim... I started off with this template that seemed like a nice and clean starting point https://github.com/LunarVim/Neovim-from-scratch I've only mostly pinned some newer (well, newest available usually) versions of different plugins to solve some other issues, no other changes. Also using newest pre-release NeoVim v0.8.0-1183-ge6c214033.

  • lua-language-server

    A language server that offers Lua language support - programmed in Lua

    I can't find anything seemingly related on google. I assume this has something to do with the LUA LSP-server which is https://github.com/sumneko/lua-language-server in this case... I don't have any any clues how can I debug this any further. :checkhealth etc. seems fine and the sumneko_lua LSP is installed and working.

  • SonarLint

    Clean code begins in your IDE with SonarLint. Up your coding game and discover issues early. SonarLint is a free plugin that helps you find & fix bugs and security issues from the moment you start writing code. Install from your favorite IDE marketplace today.

NOTE: The number of mentions on this list indicates mentions on common posts plus user suggested alternatives. Hence, a higher number means a more popular project.

Suggest a related project

Related posts