Managed - EAS Build fails for iOS Simulator

This page summarizes the projects mentioned and recommended in the original post on reddit.com/r/expojs

Our great sponsors
  • Glassfy - Build, manage, and grow in-app purchases and subscriptions
  • Appwrite - The Open Source Firebase alternative introduces iOS support
  • Scout APM - Less time debugging, more time building
  • SonarQube - Static code analysis for 29 languages.
  • JetBrains - Developer Ecosystem Survey 2022
  • Firebase

    Firebase iOS SDK

    Looks like the particular error message has appeared here, in a react-native-google-signin package. Could it be that EAS iOS build process runs on some arm64 machine and thus why this error is getting thrown? Seems unlikely though…

  • react-native

    A framework for building native apps with React. (by expo)

    Expo CLI 4.8.1 environment info: System: OS: macOS 11.3.1 Shell: 5.8 - /bin/zsh Binaries: Node: 14.17.3 - /usr/local/bin/node npm: 6.14.13 - /usr/local/bin/npm Watchman: 2021.06.07.00 - /usr/local/bin/watchman Managers: CocoaPods: 1.10.2 - /usr/local/bin/pod SDKs: iOS SDK: Platforms: iOS 14.5, DriverKit 20.4, macOS 11.3, tvOS 14.5, watchOS 7.4 IDEs Xcode: 12.5.1/12E507 - /usr/bin/xcodebuild npmPackages: expo: ^42.0.0 => 41.0.1 react: 16.13.1 => 16.13.1 react-dom: 16.13.1 => 16.13.1 react-native: https://github.com/expo/react-native/archive/sdk-42.0.0.tar.gz => 0.63.2 react-native-web: ~0.13.12 => 0.13.18 react-navigation: ^4.0.0 => 4.4.4 npmGlobalPackages: expo-cli: 4.8.1 Expo Workflow: managed

  • Glassfy

    Build, manage, and grow in-app purchases and subscriptions. Glassfy open source SDK and backend enable you to integrate and remotely manage in-app subscriptions in just minutes, so you can focus on your app.

NOTE: The number of mentions on this list indicates mentions on common posts plus user suggested alternatives. Hence, a higher number means a more popular project.

Suggest a related project

Related posts